Skip to main content

SharePoint : Update URLs after resotring a content DB of hostnamed site collections


To change or update URLS after resotring a content DB of hostnamed site collections, use
stsadm -o renamesite -oldurl http://abc.com -newurl http://abc-uat.com

You only need to rename the root hostnamed site collection. It will reflect on the other HNSC starting with the same URL.

If you try using Set-SPSiteURL on an HNSC with  same starting url, you will get the error : Could not perform this operation on the site collection
http://abc.com. To add a URL for this site collection add a URL to the root host-named site collection at http://abc.com. At line:1 char:1

Comments

Popular posts from this blog

OWA not working after security update

Office web apps for SharePoint 2013 not working after security updates / server patching. After installation of the following security patches, OWA stopped working there by causing issues with SharePoint 2013. Details of ULS logs are provided below. FarmStateReplicator.exe (0x0CD8) Office Web Apps Farm State Error when trying to connect to Farm State Manager service: System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at http:// /farmstatemanager/FarmStateManager.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.ServicePoint.ConnectSocketInternal

SharePoint 2013 workflow : The server was unable to process the request

Here, I received another SharePoint 2013 workflow error. This time the workflow was not able to send emails and the following error was being shown Retrying last request. Next attempt scheduled in less than one minute. Details of last request: HTTP Unauthorized to http://sitename/_vti_bin/client.svc/web/lists/getbyid(guid'guid') Correlation Id: id Instance Id: id Fortunately I came across this post which gave me the answer http://sharepoint.stackexchange.com/questions/89101/failed-to-retrieve-the-com-class-factory-for-component-with-clsid-sp-sprequest Solution 1: In InetMgr, go to advanced settings for Security Token Service Application Pool and change "Load User Profile" to true. Recycle application pool. Reason 2 and Solution 2 : There could be another reason for this error. The workflow authentication can fail if the user executing the workflow (this will be the user initiating the workflow) is given permission through active directory group and the co

Sharepoint 2013 Workflow - something went wrong

When I try to run a worflow created using SharePoint 2013 designer, I get the following error: "Something went wrong. To try again, reload the page and then start the workflow." Resolution: Restart these services: Service Bus Gateway Service Bus Message Broker Edit the workflow in designer and republish. ULS logs for reference: Request Management High Reached maximum number of failed machines based on ping results for this routing group Request Management Medium Mapping URI from 'http://siteCollection:80/_vti_bin/client.svc/ProcessQuery' to 'http://<SPAppServer>_vti_bin/client.svc/ProcessQuery' Logging Correlation Data Medium Name=Request (POST:http://siteCollection/_vti_bin/client.svc/ProcessQuery) Authentication Authorization Medium Non-OAuth request. IsAuthenticated=True, UserIdentityName=0#.w|<userLoginName>, ClaimsCount=25 CSOM Medium Begin CSOM Request ManagedThreadId=103, NativeThreadId=11660 Logging Corre